Some Mac users may have encountered this pop-up window when installing Insync on their machine:

For backwards-compatibility with older versions, we're still 32-bit. Apple wants only 64-bit moving forward, but we still support 32-bit for older Mac versions. :) 

Did this answer your question?